Fork me on GitHub

#1 2012-07-08 23:39:11

wishingcloud
Member
Registered: 2012-06-26
Posts: 7
Website

[FIXED] oneye 0.9.0: Upload limit problem

The upload limit of my site has become 2MB after upgrading to 0.9.0. It was 200MB before upgrade. memory_limit and upload_max_filesize is set to 600MB in my install. site is wishingcloud.net test/test

Offline

#2 2012-07-09 00:07:30

wishingcloud
Member
Registered: 2012-06-26
Posts: 7
Website

Re: [FIXED] oneye 0.9.0: Upload limit problem

wishingcloud wrote:

The upload limit of my site has become 2MB after upgrading to 0.9.0. It was 200MB before upgrade. memory_limit and upload_max_filesize is set to 600MB in my install. site is wishingcloud.net test/test

Intrestingly, It happens only with advanced installer. There on no 2mb LIMIT IF i USE SIMPLE UPLOADER.

Offline

#3 2012-07-09 19:30:17

lars-sh
Administrator
From: near Hamburg, Germany
Registered: 2011-07-14
Posts: 730
Website

Re: [FIXED] oneye 0.9.0: Upload limit problem

I just splitted the topics, don't worry wink ...

In oneye 0.9.0 RC1 and higher we added .htaccess and php.ini files containing default settings, try disabling magic_quotes and so on. "upload_max_filesize" and such are commented out, but don't hesitate to edit that file and increase those limits as you like.

wishingcloud wrote:

Intrestingly, It happens only with advanced installer. There on no 2mb LIMIT IF i USE SIMPLE UPLOADER.

That's really quite interesting. We should definitely take a look at this. Please check if the settings you set (see above) get applied correctly in simple and advanced uploaders.


Best regards,
Lars Knickrehm

The oneye project.

Offline

#4 2012-07-10 10:10:01

wishingcloud
Member
Registered: 2012-06-26
Posts: 7
Website

Re: [FIXED] oneye 0.9.0: Upload limit problem

I tried to update the local php.ini as you suggested but it didn't solve the problem. However, I was able to use my web server's php.ini after removing local php.ini. Thanks for the pointer smile

Here is how the local php.ini looks. I guess a 0 means magic quoted disabled

#
# COMPATIBILITY
#
arg_separator.output        = &
disable_classes             =
disable_functions           =
display_errors              = 1
error_log                   = ./logs/php.txt
error_reporting             = E_ALL
html_errors                 = 0
magic_quotes_gpc            = 0
magic_quotes_runtime        = 0
magic_quotes_sybase         = 0
mbstring.func_overload      = 0
register_globals            = 0
safe_mode                   = 0
session.use_cookies         = 1
session.use_only_cookies    = 1
zend.ze1_compatibility_mode = 0

#
# CLIENT-DOWNLOAD
#
file_uploads        = 1
max_execution_time  = 3600
max_input_time      = -1
memory_limit        = 600M
post_max_size       = 600M
upload_max_filesize = 600M

#
# SERVER-DOWNLOAD
#
allow_url_fopen = 1

Offline

#5 2012-07-10 10:13:13

lars-sh
Administrator
From: near Hamburg, Germany
Registered: 2011-07-14
Posts: 730
Website

Re: [FIXED] oneye 0.9.0: Upload limit problem

You shouldn't need to remove the php.ini file of oneye to upper those limits, since they were commented out originally...

But it's great to see things work now smile .

Have fun!


Best regards,
Lars Knickrehm

The oneye project.

Offline

Board footer

Powered by FluxBB