Fork me on GitHub

#1 2011-12-13 19:21:30

glynd
Member
Registered: 2011-12-13
Posts: 1

[FIXED] iPhone files not displaying correctly

I haven't seen this raised elsewhere, so apologies if I am going over old news. Using the SVN 1.9 version via an iPhone will not display some image files correctly.

Looking through the file lib.eyecode found in eyeFiles under apps in the folder structure under iphone. I think there is a typo around line 79. In my copy this is:

header("Content-Length: $len");

Correcting this to header("Content-Length: ".$len); solves my issues. I also changed in the line above the ' to " for consistency.

Another issue I found, the icons referenced in this bit of code are also missing. I corrected this by copying an appropriate existing icon and renamed it to what the script is looking for. I put the renamed icons into the 16x16 and 48x48 folder under the default theme.

I also notice there is no code to deal with audio files, although there is code to display the music, image, etc. icons. I have started adding this to my copy. Happy to share if this would be useful, however I would describe my php programming as more of a hacking style. MP3 streams quite nicely to the iPhone.

Offline

#2 2011-12-20 19:59:19

lucaferrario
Administrator
From: near Como, Italy
Registered: 2011-07-15
Posts: 91

Re: [FIXED] iPhone files not displaying correctly

Hi glynd,
many thanks, I will commit your typo-fix to the SVN in a couple of hours. Unfortunately I never use the mobile version (I prefer to use the normal version in mobile devices too, because I find the mobile version too limited and because I use oneye from notebook and tablets only (I think that oneye is much more useful on a tablet than on a smartphone)), so I don't work on it.
Anyway, please send here every bugfix or improvement you make, and I'll commit it to the SVN, so everyone can enjoy it!
Again, thank you very much!!!
Luca

Offline

#3 2011-12-21 01:09:38

lucaferrario
Administrator
From: near Como, Italy
Registered: 2011-07-15
Posts: 91

Re: [FIXED] iPhone files not displaying correctly

Ok, I just:

  • Created in the 16x16 the missing icons, which was: photo.png, music.png, video.png

  • Changed in the lib header("Content-Length: $len"); to header('Content-Length: '.$len); even though this seems very strange to me. The preceeding version should have worked too, because within double quotes the variables are interpreted by PHP. Maybe it has to do with some strange configurations of your PHP parser. Anyway, I changed it wink

It is in SVN 7317. Please tell me if I missed something wink Many thanks!

Offline

Board footer

Powered by FluxBB