Fork me on GitHub

Announcement

The oneye project has been discontinued. You might not expect further fixes and support from us. All community related systems are set to read-only mode. Though feel free to download and use oneye as-is or even fork it over at GitHub.

#1 2012-03-10 14:50:31

Lectoff
Member
From: Russia
Registered: 2012-03-10
Posts: 7

I have a problem in all browsers except Google Chrome

I have a problem in all browsers except Google Chrome, where the login page does not show how to fix the problem?

Offline

#2 2012-03-10 19:24:31

Sable
Member
From: France
Registered: 2012-02-20
Posts: 87

Re: I have a problem in all browsers except Google Chrome

Hello and welcome Lectoff,

it seems you have the same problem than in these posts... Did you ever try another hoster?


Regards.


Edit: I've tested a fresh install of oneye 0.8.0 on gofreeserve and encounter the same problem... Maybe could we create a topic to list hosters wich accept oneye without any problem roll

Last edited by Sable (2012-03-10 20:18:14)

Offline

#3 2012-03-11 00:27:20

espectalll123
Member
Registered: 2012-01-30
Posts: 36
Website

Re: I have a problem in all browsers except Google Chrome

So... Sable, you're right!

Excepting WebKit-based browsers, there are some free hosts where oneye fails. That's because they add statistic code to oneye, which most of browsers reads badly.

P. S.: How can I remove it? I can't find it! sad

Last edited by espectalll123 (2012-03-11 00:27:47)

Offline

#4 2012-03-11 08:37:42

Lectoff
Member
From: Russia
Registered: 2012-03-10
Posts: 7

Re: I have a problem in all browsers except Google Chrome

You're right, I looked at the code page in the browser, I've seen statistics counter hosting, code statistics displayed correctly only in Google Chrome

Regards.

Last edited by Lectoff (2012-03-11 08:49:04)

Offline

#5 2012-03-11 09:07:02

Lectoff
Member
From: Russia
Registered: 2012-03-10
Posts: 7

Re: I have a problem in all browsers except Google Chrome

I found a solution to this problem! statistic code hosting, stored in a file, it automatically added to every page.
I did it:
in the file .htaccess added value "php_value auto_prepend_file none"
and the statistic code will no longer be added, now in all browsers, it works correctly.

Thank you for having that pointed out to me what the problem is!

Regards.

sorry for my bad English

Last edited by Lectoff (2012-03-11 09:17:58)

Offline

#6 2012-03-11 12:21:41

espectalll123
Member
Registered: 2012-01-30
Posts: 36
Website

Re: I have a problem in all browsers except Google Chrome

Disabled from 000webhost.com using this tool: http://members.000webhost.com/analytics.php wink

Last edited by espectalll123 (2012-03-11 12:22:08)

Offline

#7 2012-03-11 13:32:17

lars-sh
Administrator
From: near Hamburg, Germany
Registered: 2011-07-14
Posts: 731
Website

Re: I have a problem in all browsers except Google Chrome

espectalll123, Lectoff, Sable,

could you reactivate it and send me your php.ini settings for auto_append_file and auto_prepend_file, please?

In case these are set, we should clear them inside our code, so others don't run into the same problem wink ...

Else your analytics might use an Apache feature instead.


Best regards,
Lars Knickrehm

The oneye project.

Offline

#8 2012-03-11 14:08:16

Lectoff
Member
From: Russia
Registered: 2012-03-10
Posts: 7

Re: I have a problem in all browsers except Google Chrome

php.ini settings for:
auto_append_file = none
auto_prepend_file = none

or

in the file .htaccess

php_value auto_prepend_file none
php_value auto_append_file none

but this method disables the statistics

Regards.

Last edited by Lectoff (2012-03-11 14:14:11)

Offline

#9 2012-03-11 14:24:31

lars-sh
Administrator
From: near Hamburg, Germany
Registered: 2011-07-14
Posts: 731
Website

Re: I have a problem in all browsers except Google Chrome

Could you check it using the following code within a php file, please?

<?php
phpinfo();
?>


Best regards,
Lars Knickrehm

The oneye project.

Offline

#10 2012-03-11 15:05:41

lars-sh
Administrator
From: near Hamburg, Germany
Registered: 2011-07-14
Posts: 731
Website

Re: I have a problem in all browsers except Google Chrome

Okay, just try out the following:

1) Remove previous fixes, so we can test the following.

2) Add the following code beyond line 21 in eyeOSxxxxxxxxxx/system/kernel/compat.eyecode .

ini_set('auto_append_file', null);
ini_set('auto_prepend_file', null);

3) Does this help? In case it does, I'll commit it to SVN for the next releases and none will have the same problem again smile !


Best regards,
Lars Knickrehm

The oneye project.

Offline

#11 2012-03-12 05:37:30

Lectoff
Member
From: Russia
Registered: 2012-03-10
Posts: 7

Re: I have a problem in all browsers except Google Chrome

Hmm, I tried to add auto_append_file and auto_prepend_file, but it did not help. I can not understand what the cause through .htaccess everything works fine.

Regards.

Last edited by Lectoff (2012-03-12 05:46:51)

Offline

#12 2012-03-12 09:59:34

lars-sh
Administrator
From: near Hamburg, Germany
Registered: 2011-07-14
Posts: 731
Website

Re: I have a problem in all browsers except Google Chrome

Thanks for the feedback.

Is anybody interested in a FAQ in the wiki? This could be one topic there.?!


Best regards,
Lars Knickrehm

The oneye project.

Offline

#13 2012-03-12 17:05:44

Lectoff
Member
From: Russia
Registered: 2012-03-10
Posts: 7

Re: I have a problem in all browsers except Google Chrome

it would be great! but I'm too bad know English: (

Offline

Board footer

Powered by FluxBB